Update Eclipse mit Android-Entwicklungswerkzeugen v. 23

Ich habe Eclipse mit den neuen SDK-Tools aktualisiert (rev. 23), aber jetzt, wenn Eclipse startet, erhalte ich den Fehler:

Dieses Android SDK benötigt Android Developer Toolkit Version 23.0.0 oder höher. Aktuelle Version ist 22.6.3.v201404151837-1123206. Bitte aktualisieren Sie ADT auf die neueste Version.

Es wurden keine Updates mit "Check for updates" gefunden . Wenn ich versuche "Neue Software installieren" , kann ich Version 23 sehen, aber ich kann nicht aktualisieren wegen der folgenden Fehler:

Cannot complete the install because of a conflicting dependency. Software being installed: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622) Software currently installed: Android Developer Tools 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.product 22.2.1.v201309180102-833290) Only one of the following can be installed at once: ADT Package 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.package 22.6.3.v201404151837-1123206) ADT Package 23.0.0.1245622 (com.android.ide.eclipse.adt.package 23.0.0.1245622) Cannot satisfy dependency: From: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622) To: com.android.ide.eclipse.adt.package [23.0.0.1245622] Cannot satisfy dependency: From: Android Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.feature.group 22.6.3.v201404151837-1123206) To: com.android.ide.eclipse.adt.package [22.6.3.v201404151837-1123206] Cannot satisfy dependency: From: ADT Package 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.feature.group 22.2.1.v201309180102-833290) To: com.android.ide.eclipse.adt.feature.group 22.2.0 Cannot satisfy dependency: From: Android Developer Tools 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.product 22.2.1.v201309180102-833290) To: com.android.ide.eclipse.adt.package.feature.group [22.2.1.v201309180102-833290] 

Nach dem Download der letzten ADT von der Website, scheint es, gibt es ein anderes Problem.

Mit SDK Tools rev. 23 Proguard ist nicht installiert, der Ordner SDK dir/tools/proguard fehlt und andere Tools fehlen. Diese Version enthält mehrere Fehler.

  • Problem beim Ausführen von Junit-Tests in Eclipse 3.4.1 auf Mac OS
  • Inspektion der Android-Datenbank von Eclipse
  • Gibt es eine Möglichkeit, wie man mehrere lokalisierte string.xml Dateien in einem Fenster in Eclipse bearbeiten?
  • Java.lang.VerifyError: Erwartung eines Stackmap-Frames am Verzweigungsziel 57
  • Verwenden von android.support.v7.widget.CardView in meinem Projekt (Eclipse)
  • 3.2 sdk Plattform installieren Problem. "Erledigt. Nichts wurde installiert "
  • Eclipse hat mehrere Kopien von demselben Android-Gerät
  • Genymotion Plugin kann nicht in Eclipse angezeigt werden
  • 30 Solutions collect form web for “Update Eclipse mit Android-Entwicklungswerkzeugen v. 23”

    Google hat ADT v23.0.2 veröffentlicht. Dies löste viele Probleme der vorherigen ADT Version 23.

    Schritt für Schritt:

    • Menü Hilfe → Neue Software installieren …
    • Wählen Sie für "Arbeiten mit" die Android-Quelle https://dl-ssl.google.com/android/eclipse Arbeit mit Android-Quelle
    • Tick ​​ADT v23.0 für die Installation, dann klicken Sie auf "Weiter"
    • Eclipse zeigt "Install Remediation Page", da es Konflikte mit der vorherigen Version gibt. (Wenn dies nicht der Fall ist, siehe unten.) Wählen Sie "Meine Installation aktualisieren, um mit den installierten Systemen kompatibel zu sein", um die alte Version zu deinstallieren und die neue zu installieren. Danach mit den üblichen Schritten vorgehen.

    Setzen Sie die Sanierungsseite ein

    Anmerkung: Als ich die neue Version von ADT installierte, habe ich nicht die neue Version von "Android Native Development Tools" Paket enthalten. Stattdessen habe ich zuerst den Rest der Pakete installiert und dann "Android Native Development Tools" installiert. Aus einem Grund, wenn ich versuche, alle neuen Pakete einschließlich "Android Native Development Tools" zu installieren, schlägt die Installation fehl.

    Wenn es keine "Remediation-Seite" gibt, ist die einzige Möglichkeit, das ADT-Plugin von Eclipse zu entfernen, zum Menü HilfeÜber EclipseInstallationsdetails und deinstallieren von dort aus . Aber es besteht die Gefahr, Eclipse selbst zu deinstallieren.

    Google-Antwort :

    Dies ist ein Verpackungsfehler. Die gesamte Proguard-Datei fehlt. Wir haben ein Update so schnell wie möglich, aber bis dahin musst es einfach von einer früheren Version der Tools kopieren:

    Und kopiere über folgende Dateien:

    • Tools / hprof-conv
    • Werkzeuge / Unterstützung / Annotationen.jar
    • Werkzeuge / Proguard

    Also am Ende, wenn du von einer neuen ADT Kopie von Hand die Dateien begonnen hast πŸ™‚

    Bearbeiten: Mit der neuesten ADT-Version, sollte das Bündel jetzt mit Auto-Update arbeiten, also installieren Sie diese neuen Versionen :

    Versuchen Sie nicht, von der vorherigen Version zu aktualisieren, da es überhaupt nicht funktioniert. Wenn du Probleme mit zipalign hast, ist es jetzt unter Build-Tools und nicht mehr unter Tools / so kannst du einen symbolischen Link machen oder ihn einfach in den erwarteten Ordner kopieren.

    Keiner der anderen Antworten arbeitete für mich mit dem ADT-Bundle auf developer.android.com veröffentlicht.

    Ich habe die neueste Version von Eclipse heruntergeladen und nicht das ADT-Plugin über das Menü HilfeNeue Software installierenhttps://dl-ssl.google.com/android/eclipse (erwähnt von @RED_ ).

    Ich musste auch meinen Arbeitsbereich aktualisieren, um auf meinen vorherigen Arbeitsbereich zu verweisen, und die meisten Dinge schienen wiederhergestellt zu werden.

    Auf einer Seite beachten: Das scheint eine gute Zeit zu migrieren zu Android Studio …

    HINWEIS: Verwenden Sie diesen Ansatz mit Vorsicht, da dies Ihre Eclipse-Installation brechen könnte (siehe Kommentare) .

    Dies könnte Ihnen helfen, wenn Sie das ADT-Plugin manuell installiert haben. Aber wenn du die Version von Eclipse aus dem Eclipse ADT Bundle benutzt hast, kannst du die Eclipse-Installation brechen und du kannst Eclipse nicht wieder verwenden!

    Gehe zu

    Menü HilfeÜber Eclipse SDKInstallationsdetails .

    Jetzt sehen Sie alle 22.0 Versionen und klicken Sie dann auf Uninstall Button unten.

    Nach der Deinstallation:

    Menü HilfeNeue Software installierenhttp://dl-ssl.google.com/android/eclipse/

    Dann installieren Sie alle Dinge, und jetzt ist es bereit.

    Ich habe meinen Build-Server heute aktualisiert und stieß auf das gleiche Problem. Es wurde hier berichtet: https://code.google.com/p/android/issues/detail?id=72419

    Das Update ist im Gange und die Arbeit rund um den Projektleiter ist:

    Bitte warten Sie auf eine aktualisierte Version innerhalb eines Tages oder zwei. Bis dahin ist Ihr Workaround zu tun, um eine von herunterzuladen

    http://dl.google.com/android/android-sdk_r22.6.2-linux.tgz

    http://dl.google.com/android/android-sdk_r22.6.2-windows.zip

    http://dl.google.com/android/android-sdk_r22.6.2-macosx.zip

    Und kopiere über folgende Dateien:

      tools/hprof-conv tools/support/annotations.jar tools/proguard 

    [Edit] zipalign fehlte auch für mich, um zu sehen, ob du das auch kopieren musst

    Für mich geht das πŸ™‚

    Wenn aus irgendeinem Grund Sie eine ADT-Vorschau installiert haben und wieder auf den aktuellen Stall zurückkehren müssen, können Sie den Dialog nicht verwenden, um "neue" Software zu installieren, da was Sie wollen, ist eigentlich ein älterer. Stattdessen:

    • Öffnen Sie Hilfe> Über Eclipse … unter Windows oder Linux. Auf Mac verwenden Sie das App-Menü> Über …
    • Klicken Sie auf die Schaltfläche "Installationsdetails".
    • Wählen Sie die Registerkarte "Installationsverlauf".
    • Wählen Sie eine der vorherigen Konfigurationen aus.
    • Klicken Sie unten auf die Schaltfläche "Zurücksetzen".

    Bildbeschreibung hier eingeben

    Ich habe folgendes getan, um ein Problem zu lösen.

    1. Gehen Sie zu http://developer.android.com/sdk/installing/installing-adt.html und laden Sie die neueste ADT ZIP-Datei herunter (am unteren Rand der Seite).

    2. Gehe zu Eclipse → Menü HilfeÜber EclipseInstallationsdetails

    3. Löschen von Android DDM, Android Entwicklungstools, Hierarchie Viewer, Native Entwicklungstools, TraceView, etc., 22.X Version .

    4. Menü Hilfe * → Neue Software installierenHinzufügenArchiv → * Wählen Sie die heruntergeladene ZIP-Datei in Schritt 1 aus.

    5. Wählen Sie die neueste Version von 23 aus, die ich in Schritt 3 gelöscht habe und akzeptiere die Lizenzvereinbarung.

    Starten Sie Eclipse neu, und es behebt mein Problem.

    Ist das, was sie dazu sagen:

    OK, Jungs, Entschuldigung über all diese Schwierigkeiten, und wir entschuldigen uns für die verpassten Releases. Hier ist die Zusammenfassung:

    Beginnend mit ADT Bundle 23.0.2 sollten Sie in der Lage sein, auf zukünftige Versionen von ADT zu aktualisieren.

    Quelle: https://code.google.com/p/android/issues/detail?id=72912

    Nur geholfen:

    1. Frische Eclipse-Installation ( http://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/lunar )
    2. Hilfe -> Neue Software installieren -> https://dl-ssl.google.com/android/eclipse/

    Wenn du eine neue Eclipse- Version installierst, wird es funktionieren. Hier ist was ich tat:

    1. Installiert die neue Eclipse Version, Luna
    2. Eine Sicherungskopie des aktuellen Arbeitsbereichs gemacht.
    3. Ran die neue Eclipse, Luna, und aktualisiert den Arbeitsbereich
    4. Installiert das ADT-Plugin (Hilfe -> Neue Software installieren)
    5. Neu gestaffelte Eklipse
    6. Erledigt

    In diesem Thread gibt es viel Verwirrung. Es gibt zwei Lösungen, je nachdem, wie Sie ADT installiert haben.

    1. Wenn Sie das ADT-Plugin manuell installiert haben, dann glaube ich, dass Sie den "Delete ADT" -> "Neue Software installieren" verwenden können.

    2. Wenn Sie das ADT Bundle verwenden, dann folgen Sie dieser Lösung nicht! Du wirst Eclipse brechen. Hier ist ein Update von einem Google-Mitglied – lesen Sie # 18:

      https://code.google.com/p/android/issues/detail?id=72912

    Sie müssen eine neue Version des ADT-Bundles herunterladen (ja, es ist frustrierend!).

    • Deinstallieren Sie einfach die vorherigen ADT.
    • Gehen Sie zu Menü HilfeÜber EclipseInstallationsdetails
    • Deinstallieren Sie alle Plugins, die Id mit com.android.ide starten
    • Installiere ADT erneut von der Update-Site.

    MACH DAS NICHT

    Warnung: Bitte beachten Sie die Kommentare unterhalb dieser Antwort. Diese Schritte haben für viele Menschen einen negativen Einfluss gehabt.

    1. Klicken Sie auf Hilfe / Neue Software installieren …
    2. Klicken Sie auf Was ist "bereits installiert" (wie im Bild unten)
    3. Im neuen Fenster kannst du das alte ADT deinstallieren (deinstallieren Sie Android Development Tools, Android DDMS, Android Hierarchy Viewer, Android TraceView, Android Native Entwicklungstools und Tracer für OpenGL ES)
    4. Eclipse neu starten
    5. Dann nochmals auf Hilfe / Neue Software installieren
    6. Wählen Sie ADT … Installieren

    Ich hoffe, es hilft!

    Bild Demonstration

    Nachdem ich die Ansätze in anderen Antworten ohne Erfolg ausprobiert habe, habe ich gerade ein neues Bündel von http://developer.android.com/sdk/installing/index.html?pkg=adt installiert und das hat gut geklappt.

    Mach Folgendes:

    1. Wenn Sie nicht alle Plattformen erneut herunterladen möchten, kopieren Sie die vorhandene von / OLD_ANDROID_SDK_PATH / sdk / Plattformen zu / NEW_ANDROID_SDK_PATH / sdk / Plattformen .
    2. Wenn Sie die neue Eclipse aus dem letzten heruntergeladenen Bundle öffnen, stellen Sie sicher, dass Sie den vorherigen 'Arbeitsbereich' Ordner wiederverwenden. Damit wird sichergestellt, dass alle vorherigen Einstellungen in Erinnerung bleiben.
    3. Nach dem Öffnen der neuen Eclipse auf dem vorherigen Arbeitsbereich, überprüfen Sie bitte, ob das verwendete Android-SDK auf das neue zeigt (Eclipse-Einstellungen -> Android). Es könnte auf das alte hinweisen, da du die Vorschau-Arbeitsbereich-Einstellungen wiederverwendet hast.

    Mit diesen Schritten musst du nicht alles neu konfigurieren, und du brauchst keine Zeit damit zu verbringen, diesen BUG bei diesem Upgrade von Google Developers zu beheben.

    Viel Glück! πŸ˜‰

    Sie müssen die alte Version deinstallieren und 23 installieren

    Deinstallieren: Hilfe> über Eclipse SDK> Installationsdetails Wählen Sie Android verwandte Pakete zum Deinstallieren

    Und dann installieren Sie V23.

    Es gibt keine Möglichkeit, ein vorhandenes ADT-Bündel zu aktualisieren, das Sie heruntergeladen haben könnten.

    Sie können eine von zwei Optionen:

    1. Installiere Eclipse von eclipse.org und installiere ADT, indem ich auf die Update-Site hinweist: https://dl-ssl.google.com/android/eclipse

    2. Bündel herunterladen von:

    Beginnend mit ADT Bundle 23.0.2 sollten Sie in der Lage sein, auf zukünftige Versionen von ADT zu aktualisieren.

    Ich bekam die gleiche "widersprüchliche Abhängigkeit" Fehler auf Mac OS X 10.9.3 und einfach Upgrade war keine Option. Was endlich gearbeitet hat, war das Herunterladen der neuesten Eclipse ADT Bündel Zip-Datei von developer.android.com, extrahiert es und bewegt nur "Eclipse" Ordner an den Ort, wo meine alten Eclipse-Ordner war. (Extrahieren der Eclipse ADT Bündel Zip-Datei wird Ihnen "Eclipse" und "sdk" Ordner).

    Wenn Sie sich entscheiden, die gleiche Route zu gehen, stellen Sie zunächst sicher, dass Sie wissen, was Ihr Workspace-Pfad ist. Dies finden Sie unter Einstellungen. Dann benennen Sie Ihr altes "Eclipse" -Verzeichnis (nicht Eclipse.app) zu etwas wie Eclipse-22.6.3, dann verschieben Sie extrahierten "Eclipse" Ordner an seinen Platz. Führen Sie neue Eclipse.app innen, und wenn es Sie fragt, über Workspace, geben Sie einfach den gleichen Weg wie Sie oben erwähnt. Oder es kann auch später in den Einstellungen eingestellt werden.

    Vielleicht wert Hinzufügen ist, dass die Wiederherstellung Android SDK Manager und Android Virtual Device Manager wählen Sie Fenster -> Anpassen Perspektive -> Befehlsgruppen Verfügbarkeit und wählen Sie Android SDK und AVD Manager . Dies fügt diese 2 Elemente zum Menüpunkt "Fenster" für die aktuelle Perspektive (Java) hinzu.

    Ich habe den extrahierten "sdk" -Ordner nicht verschoben, weil ich schon sdk-Ordner im selben Verzeichnis wie eclipse hatte, was ich bereits auf die neuesten Android-Tools aktualisiert habe. Aber wenn es Ihnen fühlt sich sicherer, können Sie auch umbenennen Sie Ihre alten Sdk-Ordner (für Backup-Zwecke) und verschieben Sie die frisch extrahierte in ihren Platz.

    Ich stand dem selben Problem gegenüber und löste es. Du musst das Android-Plugin komplett aus Eclipse deinstallieren (vom "about" -Abschnitt ..), inklusive Trace-Ansicht.

    Dann fügte das ADT-Plugin erneut hinzu ( https://dl-ssl.google.com/android/eclipse/ ) und installiere es.

    Das Problem ist behoben!

    Ich denke, es ist ein Fehler mit dem SDK Manager oder ADT Plugin Update Mechanismus …

    So aktualisieren Sie von 22.xx.x auf 23.0.2 (meine Lösung). Dies wird die Abhängigkeitsfragen schlagen.

    Ich leide seit Tagen an dieser Ausgabe, und ich habe jede einzelne Lösung auf diesem Link ausprobiert, aber kein Glück. Ich habe endlich eine Lösung herausgefunden, die eigentlich funktioniert!

    Bitte beachten Sie, dass diese Lösung in Windows 7 (64 Bit) funktioniert. Es sollte wahrscheinlich für andere Windows-Betriebssysteme funktionieren.

    Auf geht's:

    1. Laden Sie das neueste ADT Bündel herunter

      http://developer.android.com/sdk/index.html#download

    2. Entpacken Sie es und öffnen Sie den Ordner "eclipse" -> "plugins"

    3. Gehen Sie jetzt zu Ihrer alten Eklipse und öffnen Sie den Ordner "Eclipse" -> "Plugins" und kopieren Sie alles im Inneren.

    4. Fügen Sie sie nun in den Ordner "plugins" des (NEW ECLIPSE) ein, aber überschreiben Sie nichts.

    5. Im Inneren des "Plugins" -Ordners deiner neuen Eclipse, mach die Suche. Geben Sie 22. (Hinweis 22 mit einem Punkt) und drücken Sie Enter.

    6. Das Suchergebnis zeigt alle Dateien oder Ordner mit ….. 22.6 …… Zum Beispiel,

       com.android.ide.eclipse.adt_**22.6.2**.v201403212031-1085508 
    7. Markieren Sie alle diese Dateien / Ordner und klicken Sie auf die Löschtaste.

    8. Achten Sie darauf, Ihre alte API / SDK auf die neueste Version zu aktualisieren und laden Sie dieses Sdk-Verzeichnis, um mit Ihrer neuen Eclipse zu arbeiten.

    oder

    Sie können dieses Video anschauen, das Ihnen zeigt, wie Sie Ihr SDK / API in Ihren neuen SDK-Ordner verschieben können.

    Link: https://www.youtube.com/watch?v=jPZpJdnbbN0

    Ich habe nicht versucht, von anderen ADT-Versionen zu aktualisieren, aber ich denke, es sollte für alle alten ADT-Versionen auch funktionieren.

    Vergessen Sie nicht, Sachen zu sichern, bevor Sie versuchen.

    Was ich gerade gefunden habe, ist, dass du dein ADT-Plugin in deiner Eclipse aktualisieren musst (ob eigenständig oder ADT Bundle), bevor du dein Build-Tool aktualisiert hast.

    Wenn Ihre Eclipse-Installation auf das neueste Build-Tool verweist und Ihre Eclipse ADT 22.x hat, werden diese Fehler angezeigt.

    Was für mich gearbeitet hat: (auf Ubuntu 14.04 64-bit)

    • Installiert eine ältere Version von Eclipse und ADT (aus dem Bundle)
    • Diese Kopie von Eclipse zeigte auf eine ältere SDK Verion mit alten Build-Tools (vor 20)
    • Aktualisiert die ADT auf v23 (über das Archiv, in meinem Fall)
    • Spitz Eclipse auf die neueste Version von Build-Tools.

    Sie haben möglicherweise keine ältere Kopie von Eclipse- und Build-Tools, in diesem Fall können Sie das neueste Build-Tool vom SDK Manager deinstallieren und die ältere Kopie installieren.
    Sobald alles gut läuft, mach die oben genannten Schritte.

    Ich versuche, ältere Kopien solcher Bündel irgendwo im Internet hochzuladen, die Links hier zu aktualisieren, sobald ich fertig bin.

    Ich habe diese Anleitung in einem Kommentar gefunden.

    Laden Sie die neueste Version von ADT herunter und verwenden Sie Ihren vorhandenen Arbeitsbereich. Dies ist eigentlich die am wenigsten Schmerz-Full-Upgrade Sie jemals tun. Es hat nicht mit dem .android-Ordner verwirrt, so dass ich immer noch meine ursprüngliche Debug-Taste hatte. Nur die Dinge fehlten ein paar Add-ons, die ich kaum benutzt habe und sie sind einfach in die neue Version installiert.

    Hinweis nicht in Ihren vorhandenen Adt-Ordner installieren einen neuen Ordner erstellen, so dass Sie immer noch zurückfallen können, wenn die neue Installation nicht funktioniert.

    Bei ADT-gebündelter Eclipse musste ich zuerst den ADT deinstallieren und dann eine Neuinstallation machen.

    Um das ADT-Plugin von Eclipse zu entfernen:

    • Gehen Sie zu Menü HilfeÜber EclipseInstallationsdetails .
    • Wählen Sie ADT-Plug-In und klicken Sie dann auf Deinstallieren.
    • Nach der Deinstallation installieren Sie ADT aus Hilfe → Neue Software installieren.

    Für mich hat es geholfen, Android 4.4W zu löschen, das auch API 20 ist und eine Ursache für den Konflikt sein könnte. Also nur Android Android 4.4W oder Android L installieren, bis sie es beheben.

    Und (das ist vielleicht nur für mich) es funktioniert nur in Android Studio nicht in Eclipse …

    Ich musste ADT löschen und es wieder installieren.

    Allerdings wurde man gewarnt , das hat mich und eine andere Person zu einer Annotation.jar fehlende Fehler in der Java Build-Pfad für bestimmte Projekte, wahrscheinlich weil es versucht, für ein altes SDK zu suchen, so dass die Aktualisierung von Projekten ist der nächste Schritt, den ich haben muss nehmen.

    Die Fehler beziehen sich auf Bibliotheken meist, Google Play Services, Facebook SDK, ActionBarCompat.

    Für diesen Schritt deinstalliere ADT, dann leg die URL zurück, um sie herunterzuladen. Die URL ist: https://dl-ssl.google.com/android/eclipse

    Ich fand eine Lösung für das Problem mit "widersprüchlicher Abhängigkeit". Ich habe nicht die gleiche Seite von Daniel Díaz's Antwort, aber eine Seite zeigen "widersprüchliche Abhängigkeit", und ich kann nichts machen.

    Das Problem ist, dass ich nicht der Besitzer der Datei bin. Eclipse wurde in einer anderen Sitzung (auf OS X) installiert. Ich habe das Recht, die Eclipse-Datei zu lesen und zu schreiben, aber ich bin nicht der Besitzer. Machen Sie einen "chown" -Befehl auf alle Eclipse-Dateien, um das Problem zu lösen. Danach habe ich das gleiche Ergebnis wie Daniel Diaz.

    Ich hoffe das hilft jemandem.

    WARNUNG

    Es gibt jetzt ein Update für ADT 23.0.1, aber die Windows- und Linux-Scripts sind verwechselt, also warten Sie mit dem Upgrade!

    Sie können z. B. Werkzeuge / proguard / bin / * überprüfen. http://dl.google.com/android/android-sdk_r23.0.1-windows.zip.

    I did this to solve the same issue (in OS X):

    1. Help > Install New Software > Add or select this repository " http://download.eclipse.org/eclipse/updates/4.3 "
    2. Under "Eclipse platform" select the newest version of Eclipse.
    3. The installer will ask if you want to uninstall the ADT, click finish.
    4. Restart Eclipse and install ONLY the ADT 23 using this repository: https://dl-ssl.google.com/android/eclipse .
    5. Restart Eclipse and install DDMS, Hierarchy Viewer, Trace View etc.
    6. Restart Eclipse again.

    Ich hoffe es hilft.

    If Eclipse gives an error after uninstalling the ADT plugin from your Eclipse installation, try to edit file config.ini in the Eclipse folder → configuration. Finden:

     eclipse.application= 

    And change it to:

     eclipse.application=org.eclipse.ui.ide.workbench 

    I hope it works for you too.

    I simply went to my Android resources folder on my C:/ drive ( C:/Android ), deleted the 'eclipse' folder and all its contents. I downloaded Android Developer Tools once more and just moved over the 'eclipse' folder.

    I started up and everything was fine; I had updated to version 23.

    Hopefully this helps, possibly not suitable for everyone as some of you have Eclipse modifications but for someone who, like me, wanted a quick fix and get back to developing this seemed to be the easiest path.

    I am using Eclipse v4.3 (Kepler), and this is how I solved my problem.

    Goto menu HelpInstall new software → click Add .

    In the popup, give any name (I named it as Eclipse ADT Plugin), and in the link's place, use https://dl-ssl.google.com/android/eclipse/

    Once you click OK, you will be displayed with new packages that will be installed and old packages that will be deleted. Don't worry about these packages. Klicken Sie auf OK .

    New packages will be installed, and this should solve your problem.

    Das Android ist ein Google Android Fan-Website, Alles ΓΌber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.