Tag: android gradle

Warum kann ich keine Low-Version-BuildTools verwenden?

Wenn ich 25.0.0 verwende, erscheint mein Projekt etwas Bug (Floating Action Button zeigt nicht). Aber ich kann die richtige Version wählen. Fehler: Die SDK Build Tools Revision (24.0.3) ist zu niedrig für das Projekt ': app'. Mindestens erforderlich ist 25.0.0

Gradle druckt Warnung, obwohl SuppressWarnings gesetzt ist

Ich habe eine Android-App in Android Studio importiert. Es gibt einige Java-Bibliotheken enthalten. Alles funktioniert so weit. Die folgende Methode: @SuppressWarnings("deprecation") private Drawable getDrawable() { if(Build.VERSION.SDK_INT > Build.VERSION_CODES.KITKAT_WATCH) return activity.getResources().getDrawable(R.drawable.separator_gradient, activity.getTheme()); else return activity.getResources().getDrawable(R.drawable.separator_gradient); } Druckt immer eine abschreibungswarnung: :androidAnsatTerminal:compileDebugJava C:\…\src\main\java\de\ansat\terminal\activity\widgets\druckAssistent\FahrkartenArtSelector.java:131: warning: [deprecation] getDrawable(int) in Resources has been deprecated return activity.getResources().getDrawable(R.drawable.separator_gradient); ^ 1 warnung Dies […]

Gradle – DependencySubstitution für Android App mit einer Bibliothek

Ich habe ein Android-App-Projekt mit separaten Android-Bibliotheksmodul im Inneren, das als Binär veröffentlicht wird. Ich möchte eine Fähigkeit hinzufügen, den Gradle zwischen dem Aufbau einer Bibliothek aus Quellen oder mit dem veröffentlichten Artefakt zu wechseln. Android-App hängt standardmäßig von Binär-Artefakt ab: compile "com.example.konstantin.mylibrary:mylibrary:${mylibraryVersion}" Jetzt möchte ich, dass mein Binär-Artefakt durch den Quellcode ersetzt wird, also […]

Führen Sie firebaseUploadReleaseProguardMapping-Task aus der Datei app / build.gradle aus

Gibt es eine Möglichkeit, gradle Aufgabe aus app / build.gradle Datei laufen, so dass, wenn ich bauen Release APK Aufgabe "firebaseUploadReleaseProguardMapping" wird automatisch ausgeführt.

Android gradle: Multi-Projekt bauen, oberste Ebene build.gradle

Ich habe ein Multi-Projekt Android-Build-System. Die Struktur des Projektes ist wie folgt: Root Dir | settings.gradle | build.gradle | Apps | app 1 | build.gradle | app 2 | build.gradle | Libs | lib 1 | build.gradle | lib 2 | build.gradle Alle Apps und Bibliotheken haben eine gemeinsame Android-Konfiguration. Auf der Root-Ebene build.gradle habe […]

Android Studio erstellen eine Build-Variante / Typ ohne jniLibs?

Ich habe eine Android-Anwendung, die eine native JNI-Bibliothek verwendet. Ich habe es in app/src/main/jniLibs/armeabi-v7a ohne irgendeine gradle Konfiguration und Android Studio glücklich bündelt es in die APK. Ich habe eine Anforderung, wo alle nativen Bibliotheken nicht mit einer gewissen Verteilung gebündelt werden können. Ist es möglich, eine Build-Variante zu erstellen oder zu bauen, die einfach […]

Android Studio Gradle nicht Gebäude Projekt

Ich habe mein Android Studio sehr gut benutzt. Ich weiß nicht, was passiert ist und jetzt bekomme ich nur das Gebäude "xxxx" Gradle Projekt Info wann immer ich mein neues Projekt erstellen möchte. Ich kann kein neues Projekt eröffnen. Bitte helfen Sie. Ich habe noch nicht 10 Reputationen, um den Screenshot hochzuladen. Ich glaube, meine […]

Gradle Fehler in App: packageDebug, Android Studio, Ubuntu

Ich versuche, ein Projekt in Android Studio auf Ubuntu laufen, aber es scheitert mit dem folgenden Fehler in Gradle. Error: Execution failed for task ':app:packageDebug'. > org/bouncycastle/util/Store Ich habe mit Android Studio in Windows, aber nie über diesen Fehler kam. Ich habe versucht, dies zu tun, aber es hat nicht funktioniert. Bitte führen Sie mir, […]

Android Studio Error JUNIT4 !!! JUnit Version 3.8 oder später erwartet:

Ich mache Android-Projekt (in Android Studio), mit einem kleinen SDK drinnen ist das reine Java. Also, was ich will, ist Test von JUnit4 zu testen. Und ich habe die Gradlle File so konfiguriert: apply plugin: 'android' android { compileSdkVersion "Google Inc.:Google APIs:19" buildToolsVersion "19.0.1" lintOptions{ checkReleaseBuilds false } defaultConfig { minSdkVersion 8 targetSdkVersion 19 versionCode […]

Wie kann ich eine nette Bibliothek in Android Studio verknüpfen?

Ich verwende derzeit eine Bibliothek, die ich bereits in .so Dateien kompiliert .so . Ich habe die Bibliothek in jniLibs und ich lade es mit: System.loadLibrary("library"); Nun möchte ich diese Bibliothek in einigen meiner eigenen nativen Code verwenden, also wie kann ich diese .so Dateien mit meinen eigenen nativen Dateien aus dem jni Ordner jni […]

Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.