Tag: android gradle

Android Studio Execution fehlgeschlagen für Task ': app: preDexDebug'

Dieses seltsame Verhalten ist mit meiner Build-Anwendung passend. Die seltsame ist, dass diese com.nineoldandroids ist ein Glas, das aus Android-Ressourcen-Bibliotheken ist. Ich habe versucht, bauen Quelle zu löschen und wieder zu kompilieren ohne Glück. Mein buildgradle: buildscript { repositories { maven { url 'http://download.crashlytics.com/maven' } } dependencies { classpath 'com.crashlytics.tools.gradle:crashlytics-gradle:1.+' } } apply plugin: 'com.android.application' […]

Konnte die Eigenschaft 'aild' nicht finden

Ich habe vor kurzem auf Android Studio 0.5 und Android-Gradle Plugin 0.9 aktualisiert. Jetzt ist mein Projekt nicht erfrischend / synchronisiert. Ich bekomme folgende Fehlermeldung: Ich habe überprüft, dass das build.gradle im Projektwurzel die 0.9. + Version von gradle verwendet. Wie kann ich dieses Problem lösen?

Build-Skript-Fehler, nicht unterstützte Gradle DSL-Methode gefunden: 'release ()'! Wenn man sich auf 0.5.1 aussetzt

Nicht in der Lage, diesen Fehler zu lösen, habe ich Android Studio aktualisiert. Gegangen throungh andere diese Lösungen aber nicht für mich gearbeitet, bitte helfen .. Build-Skript-Fehler, nicht unterstützte Gradle DSL-Methode gefunden: 'release ()'! Mögliche Ursachen könnten sein: – Sie verwenden Gradle-Version, wo die Methode abwesend ist – Sie haben kein Gradle-Plugin angewendet, das die […]

AndroidStudio (0.8.9 Mac) Neues Projekt Gradle konnte nicht synchronisiert werden

Ich bin während meiner Bewertung von Android Studio (0.8.9 auf Mac) wegen eines Gradle-Synchronisationsfehlers blockiert. Ich habe schon nach anderen Problemen wie bei StackOverflow gesucht (wie zB Gradle Projekt Refresh fehlgeschlagen (AS 0.8.2, Mac) ), aber ohne eine Lösung zu finden. Sofort, als ich ein neues Android-Projekt mit Android Studio schaffe, bekam ich folgende Fehlermeldung: […]

Wo kann ich die neueste Version NUMBER des Constraint Layouts überprüfen?

Ich verwende das Layout in meiner App. Doch der Layout-Editor springt mir eine Warnung, dass ich die veraltete Bibliothek verwende: Verwenden Sie die Version 1.0.0-alpha9 der Constraint-Bibliothek, die veraltet ist In meiner gradle datei habe ich: com.android.support.constraint:constraint-layout:1.0.0-alpha9 Wo kann ich überprüfen, welche ist die neueste (up-to-date) Version dieser lib? BEARBEITEN: Die Frage ist "Wie weiß […]

Upgrade-Problem in der Version von gradle build tools von 1.2.3 bis 1.3.1

Ich habe die Gradle-Build-Tools von 1.2.3 auf 1.3.1 aktualisiert und begonnen, den folgenden Fehler auf gradle sync zu sehen. Ich hatte keine Probleme mit 1.2.3 Version. Ich bin auf gradleVersion 2.3. Gibt es trotzdem kann ich diesen Fehler vermeiden? Fehler: Ihr Projekt enthält 2 oder mehr Module mit der gleichen Identifikation com.salesforce.android:AndroidCommon bei ": AndroidCommon" […]

Build.gradle Fehler beim Kompilieren 'com.firebase: firebase-client-android: 2.5.0'

Ich versuche, Firebase zu meiner Android-App zu verwenden und nach der Anweisung von https://www.firebase.com/docs/android/quickstart.html zu folgen, um zu meinem build.gradle hinzuzufügen: dependencies { compile 'com.firebase:firebase-client-android:2.5.0+' } und auch android { … packagingOptions { exclude 'META-INF/LICENSE' exclude 'META-INF/LICENSE-FIREBASE.txt' exclude 'META-INF/NOTICE' } } Aber wenn ich das Projekt laufe. Es produziert mir verschiedene Fehler jedes Mal, wenn […]

Renderscript nicht kompilieren mit Build-Tools 25.0.0+

Ich bekomme den folgenden Fehler nach dem Aktualisieren, um Werkzeuge zu erstellen 25.0.2 (mit 23.0.2 Es funktionierte ganz gut): Error:target API level '25' is out of range ('11' – '24') Error:Execution failed for task ':app:compileDevDebugRenderscript'. > com.android.ide.common.process.ProcessException: Error while executing process /usr/local/opt/android-sdk/build-tools/25.0.2/llvm-rs-cc with arguments {-O 3 -I /usr/local/opt/android-sdk/build-tools/25.0.2/renderscript/include/ -I /usr/local/opt/android-sdk/build-tools/25.0.2/renderscript/clang-include/ -p /<redacted>/app/build/generated/source/rs/dev/debug -o /<redacted>/app/build/generated/res/rs/dev/debug/raw -target-api […]

Versuche, die Eigenschaft 'main' aus einer Nur-Lese-Ansicht des Modell-Elements 'android.sources' zu lesen, die zur Regel android.sources {…}

Also möchte ich ein Augmented Reality SDK ( ARToolkit ) verwenden Leider sind die angegebenen Codebeispiele ein wenig veraltet (mit gradle 0.8 und stuff), also musste ich die gradle file ein wenig ändern. Ich habe jetzt den folgenden Fehler: Error:Attempt to read property 'main' from a write only view of model element 'android.sources' given to […]

Gradle Projekt-Refresh fehlgeschlagen in Android Studio 1.2.1.1

Ich habe Beispielprojekt auf der Neuinstallation des Android Studio v 1.2.1.1 erstellt und ich habe mit dieser Fehlermeldung konfrontiert: Gradle project refresh failed in Android Studio 1.2.1.1 Siehe Bild unten: Also habe ich versucht, irgendeine Lösung auf dem Google zu finden und ich überprüfte Gradle.properties file wo ist: dependencies { classpath 'com.android.tools.build:gradle:1.2.2' // NOTE: Do […]

Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.